# Created by: David Chisnall <theraven@FreeBSD.org>
# $FreeBSD: head/devel/cheritrace-devel/Makefile 412346 2016-04-01 14:00:51Z mat $

PORTNAME=	cheritrace
PORTVERSION=	0.0.1
CATEGORIES=	devel security

MAINTAINER=	theraven@FreeBSD.org
COMMENT=	Library and tool for interacting with CHERI streamtraces.

USES=		cmake
USE_GITHUB=	yes
GH_ACCOUNT=	CTSRD-CHERI
GH_TAGNAME=	a7ddf11

BUILD_DEPENDS+=	llvm-config-cheri:devel/llvm-cheri
LIB_DEPENDS+=	libLLVMCore.so:devel/llvm-cheri

CMAKE_ARGS+=	-DLLVM_CONFIG=${LOCALBASE}/bin/llvm-config-cheri

.include <bsd.port.mk>