# Created by: ijliao
# $FreeBSD: head/games/textmaze/Makefile 412346 2016-04-01 14:00:51Z mat $

PORTNAME=	textmaze
PORTVERSION=	1.2
CATEGORIES=	games perl5
MASTER_SITES=	http://www.robobunny.com/projects/textmaze/ \
		LOCAL/ehaupt
DISTNAME=	${PORTNAME}_v${PORTVERSION}

MAINTAINER=	ehaupt@FreeBSD.org
COMMENT=	Generates mazes on a text terminal and lets you traverse them

RUN_DEPENDS=	p5-Curses>=0:devel/p5-Curses

USES=		shebangfix perl5
NO_BUILD=	yes

SHEBANG_FILES=	textmaze
PLIST_FILES=	bin/textmaze

WRKSRC=		${WRKDIR}/TextMaze

do-install:
	${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin

.include <bsd.port.mk>