# $FreeBSD: head/www/hs-yesod-core/Makefile 394918 2015-08-20 23:02:14Z pgj $

PORTNAME=	yesod-core
PORTVERSION=	1.4.13
CATEGORIES=	www haskell

MAINTAINER=	haskell@FreeBSD.org
COMMENT=	Creation of type-safe, RESTful web applications

LICENSE=	MIT

USE_CABAL=	aeson>=0.5 auto-update blaze-builder>=0.2.1.4 blaze-html>=0.5 \
		blaze-markup>=0.5.1 case-insensitive>=0.2 cereal>=0.3 \
		clientsession>=0.9.1 conduit>=1.2 conduit-extra cookie>=0.4.1 \
		data-default exceptions>=0.6 fast-logger>=2.2 http-types>=0.7 \
		lifted-base>=0.1.2 monad-control>=0.3 monad-logger>=0.3.1 mtl \
		mwc-random old-locale>=1.0.0.2 parsec>=2 path-pieces>=0.1.2 \
		primitive random>=1.0.0.2 resourcet>=0.4.9 safe semigroups \
		shakespeare>=2.0 text>=0.7 transformers-base>=0.4 unix-compat \
		unordered-containers>=0.2 vector>=0.9 wai>=3.0 \
		wai-extra>=3.0.5 wai-logger>=0.2 warp>=3.0.2 word8

.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>